Non-programmer newbie: trouble adding CNAME


#1

I’m using the “domainsinseconds” hosting service and it gives me the following error when I try to create a CNAME (I’m leaving the name blank with hopes of using “mydomain.com”, not a sub-domain): “ERROR - A record of a different type exists for the hostname @, could not create CNAME” …but I don’t see any existing records for @ (i.e. blank).

I’m guessing this is a difficult problem to troubleshoot without logging in to my hosting service to poke around…any chance someone could do that for me?

(attached image of DNS control panel…hopefully this doesn’t show any sensitive information)


#2

Hello mcdonnell.se

Setting up a CNAME for the first time can be confusing if you’ve never done it before. Thanks for reaching out to ask. And thank you for providing an image - always very helpful in these situations! I have downloaded a copy for our reference, so you can take the image down now if you are concerned about your privacy. If you ever want to ask our advice via a more private channel you can always email ‘support@unbounce.com

My read of the instructions on your control panel is that you need to enter a subdomain of some kind in Alias Name field. (the ‘@’ example they give seems to refer to the ‘Points To’ field.)

Have you tried doing this?

Let me know if you have or not and I will continue to guide you through the CNAMEing process.

JM


#3

Hi Jason,

A quick, and patient, response on a Saturday night - amazing :slight_smile:

Nice observation on the @ only working in the “points to” field. So I actually typed out www.mydomain.com (inserting my actual domain name for “mydomain”) for the “Alias Name” field (instead of using @ as I was previously) and I set the “points to” to “unbouncepages.com

Then I had to delete the existing “www” cname because the hosting service gave me an error for having multiple “www” Aliases (aliasi?)

So…I think I now have CNAME success, but unbounce’s account -> custom domain tab still says “not working yet”

(attached another screenshot showing the new CNAME circled in red)

Hopefully this makes sense, I feel like my writing becomes incoherent around this time of day.

Thanks again,


#4

Thank you for the compliment!

Like any domain name change it can take a little while for the CNAME to propagate accross the internet.

If you send an email to support@unbounce.com including the email address that your Unbounce account is registered to, I will take a look to see if everything looks ok on our end, and keep an eye on it for you to see if its working.

We realize that CNAMEing can be frustrating, so we are looking at ways of making the process as painless as possible. Any feedback you have for us on this would be very much appreciated! Its the one piece of the puzzle we can’t automate unfortunately! but we do want to provide as much help as we can.

I will just add that its a beautiful evening here in Vancouver and I have a fantastic view of the mountains as I type this - so its very easy to be patient!


#5

It’s working!!

That was certainly frustrating, but it was user-error more than anything.

For feedback: providing on-call support definitely calmed my nerves. Perhaps you could add walk-throughs for the hosting services that aren’t part of the google guide you link to? I don’t know, I’m just thinking out loud, and that probably wouldn’t be worth your time at this point…

Anyway, thank you again for your help. I just took a few minutes to play around with creating / publishing pages and I can already tell that I’m going to love your service. Extremely happy that I found it at just the right time. I think you guys are definitely on to something big, keep up the good work.

(btw that’s Awesome that you’re in Vancouver with a view - I’m jealous)


#6

footnote:

I removed the image from my reply, but I can’t seem to edit my original post here, or mark the problem solved for that matter. Maybe I’m just missing something again, or maybe these features are limited to admins. Either way, could you remove the image from my original post, or this post as a whole? It sounds like it might be a bad idea to leave the hosting information floating around online. I doubt this specific problem/solution will be of much value to the unbounce get satisfaction community anyway.

Thanks!


#7

Success!

Glad we could help you get up and running! Thank you for your suggestions - yes, providing walk-throughs for specific hosting services is an approach we have been considering so some extra validation for the idea is useful to hear.

Glad you are enjoying the ‘Unbounce experience’ overall. We designed Unbounce to solve a problem we are familiar with ourselves as internet professionals, and we are very excited by its potential.

There are some useful articles and links on our blog that might inspire you with your project. This might be a good place to start if you are interested:

http://unbounce.com/landing-pages/

Please feel free to get in touch with any further questions or comments about Unbounce.

All the best with your campaign!

JM


#8

Hi Macdonnell.se - just received your footnote.

The only way I know of editing your original post is to use the ‘Edit’ link in the red area at the top of the thread that contains the post (see attached image.) Are you not seeing anything like this? If not let me know what changes you would like to make and I will contact Get Satisfaction customer support (I am not able to edit your posts.)

I can, however, mark the problem as solved, so I will go-ahead and do that.

JM


#9

Strange, maybe it’s a bug. I’m not seeing the delete or edit links, just “inappropriate” (see screenshot)


#10

Strange, maybe it’s a bug. I’m not seeing the delete or edit links, just “inappropriate” (see screenshot)


#11

Hi Mcdonnell.se

A not-too-obvious feature of Get Satisfaction is that you can still interact with a topic thread even when you are ‘signed-out’ of the site.

Confusing thing is, when you do this, not all of the functionality (including the ability to edit posts) is available.

Are you logged-in to Get Satisfaction?


#12

Yeah, I’m definitely signed in though. Same account I made the original posting with.


#13

Hmn. Ok. Very strange.

I have submitted a support request to Get Satisfaction, described the situation and asked them to advise.

(support #1766)

Perhaps they can get to the bottom of this!


#14

Awesome. Thank you for your time! I probably could have submitted the request just as easily too…


#15

Fyi getsatisfaction support team:

I just posted another question with an image. This time I hit enter between the image and the text - problem solved, I can delete/edit that question.

Maybe the lack of separation between image and text in this original post caused the bug. Haven’t tried to repeat, just thought this might help

-Sean


#16

Interesting! - I guess we both learned something.

No worries about the support request - if we are going to use Get Satisfaction for customer support its useful to be in the loop on any issues that it has. I’m curious to see what they get back with.

I just saw your other question re: the ‘a’ button in the preview screen. Will answer over on that thread…


#17

Hello Sean

I just got a reply to my support request from Get Satisfaction. Apparently you can only edit your original post within 15mins of making it (good to know!)

They have offered to to make the edit for you. If you want to do this please drop me an email and I will forward the support response to you.

All the best - JM