Favicon not working?

  • 10 April 2024
  • 3 replies


Hello - our favicon works on some pages but not others, despite the code showing up on both pages.


Not working:

<link rel="icon" type="image/x-icon" href="">

Any help would be much appreciated!

3 replies

Userlevel 4

Hi @synca,


Thanks for your message. I checked out the 2 links and yes, I’m seeing the same thing. I have a couple of questions for you:

  1. Was the favicon link added at the domain level via Script Manager or in the ‘Javascripts’ section in the editor?
  2. Looking at the link in the page source, I see there’s a space between the favicon URL and the script closing tag. Could you try removing this space and republishing the page to see if it makes a difference?
  3. Have you contacted our Support team to rectify the problem? They would be the best people to ask in situations such as this.

Finally, I wanted to let you know that we’ve recently made an update to the Classic Builder, where you can now add the favicon directly in the page properties. Simply upload the icon to your image library, select the image and it will automatically be added:


Hope you manage to get it sorted - have a great day 😀


Thanks for the reply! 

It is loaded into Script Manager to cover the entire domain. Tried removing that space and republishing - no luck. Also tried uploading the favicon on that page in the Meta data section of Page Properties - no luck. Will reach out to support and update here with the resolution in case it can help someone else in the future!

Userlevel 4

Thanks for your reply @synca. This is most unusual. 


Looking forward to seeing what the culprit is here.