[SOLVED] Stickybar not showing in preview


#1

[UPDATE]
Sticky bars can only be previewed in the stick bar builder preview. To see them used on a host page, it will need to be published and viewed at the live URL.

[ORIGINAL MESSAGE]
Hello!

This is my first time working with stickybars and I want to test out the feature. Any guidance/assistance will be greatly appreciated!

Question Context
I’m reading the stickybar documentation and found the below Note:

“Only one embed code from each client can be added to a page at a time. If more than one embed code is added to a page, only the first one to load will fire.”

One of the pages I’m working on currently has four domain scripts and three variant scripts (one of which, is the stickybar script). My stickybar isn’t showing in the preview.

Questions

  1. Based on the above note, what is considered a “client”?
  2. Is it possible that one embed code/script is preventing the stickybar from loading? (One of the domain scripts is actually a clickable messaging feature/icon that stays on the side of the page.)
  3. Do stickybars show in a page’s editing/previewing view? Or does it have to be published to be seen?

Many thanks!
David


#2

Hey David,

Could you include a link to the page where your sticky bar should be displayed?

I’ll try to answer your questions:

  1. A client is basically your “account.” It is the set of pages you are logged into in the builder. You can see your client in the top-left of the screen in app.unbounce…

  2. It could be, I need to see the page to be sure. Each client uses the same < script > for all pop-ups and sticky bars. So it’s only going to load one at a time.

  3. Sticky bars can only be previewed in the stick bar builder preview. To see them used on a host page, it will need to be published and viewed at the live URL.

Feel free to keep asking questions if you have them :smiley:


#3

Hi Kyle,

Thanks for your insight!

I was about to send an example your way and decided to take another look at my setup. I’m sure it’ll be no big surprise, but my issue was user error.

I previously had my URL targeting to my homepage with an additional path to the subdomain I wanted this stickybar to live on.

When I made my subdomain the “homepage,” everything worked out perfectly. I even enabled the other script (chat feature) and both are running no problem.

Thanks again for your willingness to help! Have a great rest of 2018 and a happy new year!

-David