Missing form fills in API Leads call


#1

Hello,

Could you help or point me in the right direction with an API question/issue?

In a nutshell, we’re calling the unbounce API successfully via curl like below. However, for a particular advertiser the form fill results stop at Feb 14, 2018 (50 leads) and we know they have newer leads that aren’t being returned by the API.

curl -u “XXXXXXXXXXXXX:” -X GET “https://api.unbounce.com/pages/620e1dc1-7bb9-4cb4-956e-e86fed9cb39d/leads?secure=true?limit=1000” >> leads.json

I tried adding a header with a version to the API call but it returns the same data.

curl -u " XXXXXXXXXXXXX:" -H “Accept: application/vnd.unbounce.api.v0.3+json” -X GET “https://api.unbounce.com/pages/620e1dc1-7bb9-4cb4-956e-e86fed9cb39d/leads?secure=true?limit=1000” > leads2.json

Regards,
Paul


#2

Hey @pkosinski,

Ah I see what the problem is that there should be an ampersand between those two query-string parameters.

i.e.

curl -u “XXXXXXXXXXXXX:” -X GET “https://api.unbounce.com/pages/620e1dc1-7bb9-4cb4-956e-e86fed9cb39d/leads?secure=true&limit=1000” >> leads.json

Hope that helps,

H.Y.


#3

Hello H.Y. thank you for the response, that worked just fine. Appreciate your time to look into it. So is there a paypal widget or something on this site where I can buy you a Starbucks drink for your time? :slight_smile:

Best,
Paul


#4

Haha…thanks for the offer, @pkosinski, but it’s not necessary at all - just glad that I could help out :grin:

Have a great weekend!