Link url not working


Lets say i want to put in an affiliate link like this:…

The links doesnt work, and I get a 404.

What to do? Thanks!


Hi Robert. You can definitely add query parameters to a link that points to your Unbounce page. I had a quick look and couldn’t find any pages in our system for “”, though. Were you intending to publish any pages in Unbounce using that domain?


Hi Carl

I’m trying to link from my Unbounce page to that URL, not from it.
I should have expressed myself better, sorry.



Ah, gotcha, sorry. We re-write links to do click tracking, and the prefix we use is “clk”. If you don’t mind, after you click the link and you get the 404, what’s the URL in your browser?


This is my unbounce page

I’ve set the button to link to this url…

When I click the button I’m redirected as supposed but the parameters are not passed properly.


An option is of course to use an external redirect page, but thats kind of a hassle with a lot of landingpages…




Hi Robert, sorry for the late reply! I had a look at your page, and the only link I can find is to:…

not the “” link with parameters you mention above.

I just created and tested a new Unbounce page, and was able to successfully set links with parameters for both buttons and images, and have them passed to the target URL just fine.

Did you remove the “” links for testing? Sorry if I’m misunderstanding…


Please take another look at the site, and try the “Test” link at the bottom.
Live HTTP Headers in Firefox shows that the link points to


in other words, it’s cut off just before the :


When you say “the site”, do you mean your Unbounce page, or another page somewhere? Again, sorry if I’m just not following!


The unbounce page, http://unbounce.billige-fivefingers.d…, then the “Test” link at the bottom.


Ah, ok, I was looking at the /gasp/ page you had linked above. Now I understand what you’re trying to do!

The problem is all the special characters that make up the URL in your link. Those need to be encoded (following is a helpful article on that):…

So, your URL parameter would look like this:…

That’s probably the sort of thing we should be doing automatically for you, I’ll add that to our list of tweaks…


ahhh, of course.
Well, that explains it.