I followed the instructions for integrating Unbounce and Zoho but my leads are not showing up in Zoho


#1

I followed the instructions for integrating Unbounce and Zoho but my leads are not showing up in Zoho.


#2

Hey Ed, sorry you’re having issues with your Zoho integration. We’re not aware of any general issues with it. The integration will send new leads from form submissions into Zoho, but it won’t send any previous form submissions over. And if there are any errors, you’ll see that in your page listing and page overview in Unbounce. Have you tried posting new form submissions? Also, feel free to get in touch with us at support@unbounce.com and we’ll be happy to help you out…


#3

I have had a similar problem. I think there can be a delay in the Zoho servers from time to time in picking up the data. Also could you clarify the following in more detail what you mean by “previous forms”?

I have noted that you can submit a form once…and it will eventually go into zoho (approx 10 mins sometimes instantly) but if you refresh the form using CTL F5 the new input data WILL NOT go into zoho.

Could you clarify this?

is it direct that the integration will not works


#4

Hi Colm! I was just trying to understand where Ed was running into problems, so when I said “it won’t send any previous form submissions over”, what I meant was, if you get some form submissions in Unbounce, and THEN add the Zoho integration, those form submissions received prior to configuring the integration will not be sent to Zoho.

The behaviour you’ve described (refreshing the form and then not getting it sent to Zoho) is new to us. Does the form submission get captured in Unbounce *and* not sent to Zoho?

Also, could you clarify what you mean by “is it direct that the integration will not works”, I’m just not sure what you mean.


#5

Carl,

Yes the form submission in Unbounce captures the leads…this works…but it’s subsequent transfer to Zoho does not always transfer. I have tried 4 separate tests…all were captured by Unbounce but only one transferred into my Zoho account. Is it something to do with spamming and IP addresses…it’s the only things I can think of!!

Have asked others from different IP addresses to post a lead and zoho integration works fine!


#6

Oh, also noted that when you copy a page not all the fields in the Zoho configuration filed get copied over…YOU need to re-do again


#7

I realized that the reason I wasn’t getting leads loaded into Zoho was because in Zoho, the last name field was required. Leads that came in from the landing page with empty last name fields were not added.


#8

The leads that was submitted before you configure your Zoho integration won’t be sent to Zoho.


#9

I would like to investigate it. Can you guys send me the pages url?

If you guys aren’t comfortable to post it here, you can send to my email lucas@unbounce.com

All the best,
Lucas


#10

Lucas, I think the problem has been solved, I be
Iev it was a combination of two things:

  1. As Ed says in Zoho the last name in prospects is a required field. If you do not indicate it as a required field in Unbounce the leads will not migrate into Zoho. Furthermore, I had ticked other fields in Zoho as required so my problem was highlighted further as two rothe fields required filling…it might be an idea to have some fail safe here for zoho users

  2. If all above is correct, there can be a delay in appearance of up to 20-40 minutes before the leads are shown in Zoho. Other times its done in an instant so there is no rule of thumb here.

Thanks for all our help and assistance


#11

Hello Paul,

I’m glad to hear that.
If you have any further questions or concerns please do not hesitate to reach out.

All the best,
Lucas