How To Include Hidden Form Fields in Email Lead?


I have hidden form fields setup to capture UTM information, so I can track the success of my various Pay Per Click campaigns. I also have ‘Email Me New Leads’ activated, as my team of Appointment Setters receive and follow-up the new leads.

How do I include the hidden form field information in the lead email? It currently is not captured in: {{submitted_form_data}}

Thanks so much!



Hi Dianna,

The hidden field data should show up in the lead notification email like this:

Are you sure you have the hidden fields configured properly on your form? The “Field Name and ID” of the hidden field should be the exact name of the UTM parameter, and the “default value” should be blank, like this:

And make sure you’re using a “Hidden Field” type form field when selecting from the menu on the left of the form builder.

Lastly, are you sure that when you’re testing the page, you have UTM parameters in your URL (that exactly match your form fields)? Otherwise, the hidden fields will be empty because no UTM data is being passed through the URL.

These are just some common things I can think of to troubleshoot. Let us know if you have any questions.