Google Auto-Tagging and SSL


#1

The https:// versions of my landing pages work and I can access them directly, but if I click the Google version of my ads, google auto-tagging seems to break the SSL and I get a browser message.

Went through my webhost and all domain and subdomain naked URLS redirect to the HTTPS. What setting am I overlooking?


#2

Hi @laurynb,

That’s a really weird issue you’re encountering. On initial thought, google auto-tagging shouldn’t break SSL because that just adds the “gclid” parameter to the end of the URL.

Can you provide a link to your landing page and what you’re google ads are pointing to for the landing page?

Another question, are you using Unbounce’s SSL feature or are you using the WordPress plugin and your website itself has SSL? Unbounce’s SSL feature only works if you’re using a cname (aka subdomain).


#3

Thank you for responding to my issue. I’ve disabled my Unbounce pages until I can resolve some unrelated issues. I am using Unbounce’s SSL feature with a CNAME forward to the https. We’re not using Wordpress.

Here’s a link to a page with a similar issue , though the ad that comes up for this page appends the gclid and I get a “Not Secure” browser message.