Google Analytics isn't recording Unbounce Leads

Hi All,

I am in a bit of a conundrum here. I’ve read several threads here and as well as did my research to ensure that Google Analytics is capturing the Unbounce leads via destination but it doesn’t record them.

So, I have a simple thank you page “” – and I’ve tried to up set-up the goal with the destination by following two methods:

  1. Regular expression: /thank-you-en/.±form_confirmation.html
  2. Regular expression: /thank-you-en/a-form_confirmation.html

I’ve previously also tried: equal to: /thank-you-en & /thank-you – but no joy. Interestingly, destination goal for website purchases is working perfectly fine.

I’ve also “checked” Bot Filtering > Exclude all hits from known bots and spiders as I read somewhere to do so.

Can someone please advise what it is that I could be doing wrong?

Thank you!


Anyone? Any advice/help please?

Hi @Usman_Qureshi,

Do you have a dedicated confirmation/thank-you page or a thank you popup?

Based on your post, it seems you are trying to track a thank you popup but using a thank-you page instead.


1 Like

Hi Hristian,

Thank you for your response. Yes, it’s a dedicated page and not a thank you pop-up. But I am not sure where or how I am going wrong.


Do you have unbounce pages under a subdomain?
And website purchases under a root domain?
Perhaps there’s an issue with tracking the subdomain.

Hey Dario,

Thank you for your response. No, we currently don’t have any sub-domains for this client. It’s a WP site. So pages go like this:

  1. (for Unbounce)
  2. (for Purchases)

Hope this helps.

Hi Usman, would like to help here. but I´m not an expert on this.
The only thing I could contribute with is the regular expressions I´m using for GA tracking, but they are tracking form submissions:
I wish you can solve this.

1 Like

Hi Dario, thank you for your input.

I have added this: “/thank-you-en/^/.±form_confirmation.html” as regular expression without quotes and tested, I will let you know if it has tracked anything.

Good day to you!

Hey Dario,

Just wanted to quickly update that the above mentioned method didn’t work either. :confused:

Not sure what to do at this point. Can someone else please weigh in?

Thank you all!