Form field name with foreign letters


#1

I have foreign letters in my field name and want to use dynamic text. Since the url parameter is set to the same (incl foreign letter) it won’t work since you can’t use this in a url.


#2

Hey Anders - It should work with foreign letters as well. Browsers tend to encode-decode foreign characters so they can be passed in and read.

If it’s still not working for you let me know a example of text that isn’t passing through


#3

The problem is that Unbounce won’t accept the name when I try to set the URL-parameter. It’s not the name I put in the field, it’s the name of the field it self. ‘First name’ in swedish is ‘Fšrnamn’.


#4


#5

Ah I see. Thanks for clarifying Anders

It looks like I was mistaken. At the moment we do restrict the dynamic fields from setting foreign letters. The values being passed in from the URL however should still pass in just fine even with foreign character.

I’ll mark this ticket as feedback as a improvement we should make in the future.


#6

This one should be a easy fix; just convert the field name to the varibale used according to web standards. Or š -> oe, and Œ -> aa, Š -> ea. But there is other letters in other laugeges wich there is web standards fot the translation. Another proberly quick solution is NOT to convert the standard field parameterns when you rename them. Just keep the parameter first_name for first name even if I rename it Fšrsname. :slight_smile: