Can't add/modify scripts on published page


#1

I have 3 JS scripts added to one of my landing pages. I’ve saved and published, code is being pulled just fine.

I went back to change a few of the variables in one of the code snippets, saved the page, but can’t republish. Went back in to check if the settings had been saved – nope. I’ve tried deleting an existing script, modifying it, and adding it back in as a new script, still not saving. Looks like the platform isn’t recognizing changes to the scripts once published.


#2

Hi Vitaliy - thanks for letting us know - we’re looking into this one right now and will post a reply to this thread just as soon as we have any news.


#3

Hi Vitaliy - could you let us know exactly which page you have been experiencing the problem with?


#4

I’d be happy to. Please email me with what information you need, ie URL, account name, page, etc.


#5

Hey Jason, has this been resolved?


#6

Great, works. Thanks!


#7

This topic has been closed due to inactivity. If there are any follow up questions on this topic, please contact our Customer Success team directly. 

e. support@unbounce.com
p. 1.888.515.9161


#8

Hi Vitaliy - thank you for giving me a nudge about this. We have found the cause of the problem - there is a bug - and are working on a permanent fix. In the meantime we do have a solution that will allow you to save your page.

The CDATA tag in the script block is causing the page save to fail. If you can remove the lines:

/*
and

/* ]]> */

it should be fine.

Sorry for any delay this has caused, hopefully this solution will get you going again. Please let me know if there are any further problems.